
Under 
the 

Loupe

take control of your  
lightroom catalog
B Y  R O B  S Y L V A N

We all want to feel in control of our Lightroom catalogs, but some 

of the tasks just aren’t very intuitive, or seem fraught with peril. 

Let’s break it down and step through the basics.
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Scott Kelby’s recent class on his Simplified Lightroom Image 
Management System has a lot of members thinking about 

how to clean up and take control of their Lightroom cata-

logs. I know this because of the flood of questions that have 

come into the Help Desk asking about how to do these 

types of tasks. Whether you follow Scott’s system or not, 

all Lightroom users should be in control of their Lightroom 

catalogs, so I’m dedicating this column to giving you the 

skills you need to start the new year off on the right foot. 

catalog location
The most important thing you need to know before you 

do anything is where your Lightroom catalog is located on 

your hard drive. This may seem simple, but I’ve worked with 

several people who weren’t sure, or found that the catalog 

was not where they expected it to be. To find your catalog, 

simply launch Lightroom. With Lightroom open, go to Light-

room (PC: Edit)>Catalog Settings, click on the General tab, 

and note the name of the catalog and the path to where it’s 

located. Is it where you expected? If so, great! If not, here’s 

how you can move it to a new location:

step one: Click the Show button on the General tab of 

the Catalog Settings to open the folder containing your cat-

alog in your file browser. 

step three: Copy the folder containing the Lightroom 

catalog (.lrcat) and its associated preview caches (.lrdata) 

to the location where you want it to be stored. 

step four: Once the copy operation is complete, double-

click the catalog file to open it back into Lightroom. 

Now, whether you moved your catalog or not, this next step 

is important. I highly recommend that you manually config-

ure this catalog to be the default catalog. To do this, go to  

Lightroom (PC: Edit)>Preferences, click on the General tab, 

and set the When Starting up Use this Catalog drop-down 

menu to the specific catalog you just opened (don’t use 

Load Most Recent Catalog).

Don’t forget to go back and remove the original folder 

containing your catalog if you copied it to a new location. 

Having a good backup in place is a good idea too.

renaming catalogs
When people start taking a closer look at their catalog, they 

often wonder if it’s possible to rename a Lightroom catalog, 

and it’s very easy to do this. First, quit Lightroom, open the 

Finder (PC: Explorer), and then open the folder containing 

the catalog. You should see the catalog file with an .lrcat 

file extension and its preview caches with the .lrdata file 
step two: Quit Lightroom. If prompted to back up your 

catalog, skip for now.

http://kelbyone.com/course/skelby-slim-system/
http://kelbyone.com/course/skelby-slim-system/
https://kelbyone.com/my-account/helpdesk/
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you have in place. Here’s why: It’s free, it’s built into Lightroom, 

and it’s automatic. You can just set it and forget it, and it may 

just save your bacon one day because there are some pieces 

of data that only exist in the Lightroom catalog (virtual copies, 

collection membership, flags, and individual history steps), and 

if your catalog ever gets corrupted, lost, stolen, etc., you’ll be 

so relieved that you have an exact copy of the catalog sitting 

in a safe place. I’ve even seen people who accidentally inflicted 

damage on their own catalogs (oops, I deleted a saved book 

collection) and were saved by having a recent backup copy of 

the catalog from which they could recover. Here’s how to set 

it up:

step one: Go to the General tab in Lightroom (PC: Edit)> 

Catalog Settings.

step two: Click the Back Up Catalog drop-down menu, and 

choose the frequency for the back up to run. I chose Every Time 

Lightroom Exits because I like to be reminded each time, even if  

I sometimes skip it.

extensions. Using your File Browser, you can rename 

the catalog file, but keep the file extension the same 

(.lrcat). Then, rename the preview caches the same 

way, but retain the word “Previews” or “Smart Pre-

views” in the name along with the original file exten-

sion. So, for example, if your catalog and preview 

caches were named: 

Lightroom 5 Catalog-2-2.lrcat
Lightroom 5 Catalog-2-2 Previews.lrdata
Lightroom 5 Catalog-2-2 Smart Previews.lrdata

And you wanted to change it to “Lightroom Catalog,” 

you’d end up with:

Lightroom Catalog.lrcat
Lightroom Catalog Previews.lrdata
Lightroom Catalog Smart Previews.lrdata

Once that’s done, double-click the catalog file to 

open it into Lightroom and set that as the default 

catalog via the General tab in Preferences. The name 

you choose only matters to you, so don’t feel con-

strained to keeping the version number of Lightroom 

in the file name. 

catalog backup
Okay, you know where your catalog is located, you 

may have even renamed it to something more mean-

ingful, and it’s configured as your default catalog to 

open every time you launch Lightroom. You’re now 

more in control of your catalog than a lot of other 

Lightroom users. You may be thinking about that  

catalog backup function, and how to use it. I urge 

you to use it no matter what other backup system 

That’s it. The next time you exit Lightroom on the chosen sched-

ule, you’ll be prompted to run the backup process. That prompt  

is the only place you can configure the location of where you 

want the backup copy to be saved. Ideally, and to protect 

against drive failure, you’d choose a separate drive from the one  

on which your working catalog is located. I work off my laptop, 

which usually only has one drive attached, so I direct my backup 

copies to be saved into my Dropbox folder, which are then 

synced to my other computers and the cloud. 
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One final note: When this process runs, Lightroom 

creates an exact copy of the catalog as it exists at 

that moment, and then compresses that catalog 

into a zip file (as of Lightroom 6/CC). You’ll need to 

periodically go into the folder containing the backup 

copies and delete the oldest ones. If you ever had to 

recover from a backup, you would only use the most 

recent, right? I usually only keep the most recent two 

or three on hand. 

migrating your photo library
With your catalog under control, you can now turn 

your attention to your photos, which is likely to be 

where the biggest mess can be found. The key to 

getting control over your photos is to understand the 

role of the Folders panel in the Library module. To 

that end, I urge you to read my “Under the Loupe” 
article in Issue 23 of Lightroom Magazine, which is 

entirely dedicated to the Folders panel. You’ll learn 

how to move folders, rename folders, remove folders, 

and find where your photo folders are actually located 

on your drive. 

The one task I didn’t get to cover in that column that 

every Lightroom user should know is how to migrate 

your entire photo library from one drive to another 

drive. This is useful if you want to move your photo 

library from an internal drive to an external drive, or 

if you’re running out of space and want to move to a 

new, larger drive. The process is the same. Now, you 

could use Lightroom to move the folders, but I don’t 

recommend doing that when your entire library is at 

stake. Using a move command is too risky, because if 

anything goes wrong in the middle of the transfer you 

could lose data. I prefer a technique that involves copy-

ing the folders to the new drive, and then later manually 

deleting the files from the original location. Here’s how:

step one: Open the Finder (PC: Explorer).

step two: Copy the entire folder structure with your photos  

(as-is without changing the structure) to the other drive.

step three: Open Lightroom.

step four: Once the copy operation is complete, Right-click the 

topmost-level folder in the Folders panel in Lightroom and choose 

Update Folder Location.

step five: In the resulting dialog, navigate to and select that 

same topmost-level folder in the new drive (the one you just cop-

ied over there), and click Choose.

Lightroom will update the catalog to point to the folder in the 

new location (and everything inside that folder). If you have all  

your folders/photos in a single parent folder, then you’re done, 

but if there are additional folders at the same level as that top 

folder, you just need to repeat Steps Four and Five for those 

folders. Give it a test run to make sure everything is as it should 

be before removing the originals.

Hopefully, that information will put you in a much more confident 

place with your Lightroom catalog and put you on the path to tak-

ing control of your photo library. If you feel that maybe the mess 

is just too large and you’re looking for a way to start over from 

scratch, then tune in next issue when I devote my column to just 

that. In the meantime, send your Lightroom questions to the Help 
Desk by clicking the My Account button on the KelbyOne web

site, and then choosing Help Desk. ■

ALL IMAGES BY ROB SYLVAN
CLICK TO RATE

http://img.kelbymediagroup.com/kelbyone_enterprise/lrmag_webreader/Lightroom_Magazine_Issue_23/Lightroom_Magazine_Issue_23.html#p=11
https://kelbyone.com/my-account/helpdesk/
https://kelbyone.com/my-account/helpdesk/
http://lightroomers.com
https://scottkelby.typeform.com/to/Rcm44n
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Under 
the 

Loupe
The Folders panel may be one of the most-used panels in all 
of Lightroom, but it may also be one of the least understood. 
There’s actually quite a bit of functionality in this little panel, and 
it puts a lot of data at your fingertips.

understanding the role of  
the folders panel 
B Y  R O B  S Y L V A N
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One of the most important distinctions to make is that the 

Folders panel is not a file browser. You will only see fold-

ers that have actually been through the import process. Just 

like the photos that reside within them, nothing appears in 

Lightroom unless it was introduced to the catalog first. 

The Folders panel consists of two elements—Folders and 

the Volume Browser. Folders are exactly that, the folders 

on your hard drive(s) that you’ve imported into Lightroom. 

You can import any number of folders and subfolders, and 

they’ll always be sorted alphanumerically. Subfolders will 

nest under their parent folders, which mirror the structure 

you see in your file browser (i.e., Finder or Windows Explorer) 

when looking at your disk because they’re one and the same 

set of folders.

the volume browser
I have two Volume Browsers, labeled Macintosh HD and 

DroboPhotos (see image above). Macintosh HD is my inter-

nal drive and DroboPhotos is an external drive. These are the 

names I gave these drives on my Mac. On Windows, you 

would see the relevant drive letter. 

With a glance at the Volume Browser I can tell a few 

things about my drives. First, the Macintosh HD drive shows 

a green indicator, which means that the drive has ample free 

space. In fact, it shows that 115 GB out of 465 GB are free.

Second, I can see that DroboPhotos is offline since it dis-

plays a gray indicator and the name is faded out. Since it’s 

offline, Lightroom can’t display how much free space it has. 

Once that drive is reconnected to my computer and comes 

online, the Volume Browser will change from gray to green, 

and any question marks on folders will go away. Just so you 

know, the color indicator will turn yellow as free space gets 

down to 10 GB, orange as the free space gets down to 5 

GB, then red when the disk has only 1 GB free remaining 

(hopefully, you won’t let your drive get that full).

Free space isn’t the only information the Volume Browser 

reveals. If you Right-click the Volume Browser, you can choose 

to display Disk Space, Photo Count, Status, or nothing at all. 

In addition, you can open that disk in Windows Explorer or 

Finder and even access information about that disk.

Another nice aspect of the Volume Browser is that it’s 

collapsible, which makes the Folders panel much easier to 

navigate, especially if you have multiple drives with multiple 

folders on each. The previous screen captures showed both 

of my volumes collapsed, but once they’re expanded, I can 

see my folder structure underneath.

Remember, you’ll only see imported folders displayed in 

the Folders panel. I find it preferable to always import the 

top-level or parent folder that contains all the subfolders 

where my photos are stored. This provides the benefit of 

being able to collapse that group of subfolders so the list 

doesn’t run on forever, and it makes it much easier to move 

that entire tree of folders to a new drive if necessary just by 

dragging-and-dropping the top-level folder.

Don’t worry if you haven’t imported the parent folder 

containing your photo subfolders because it can be done 

right from the Folders panel. Just Right-click the topmost 



› 
› 

k
e

l
b

y
o

n
e

.c
o

m

093

›  ›  l i g h t r o o m  m a g a z i n e  ›  ›

folder in the panel and choose Show Parent Folder. The 

parent folder will automatically appear in the Folders panel, 

and all of its subfolders that were showing previously in the 

Folders panel will be nested underneath. For example, you 

can see that my top-level folder is named Imported_Pho-

tos, but I know that folder is stored inside my Pictures par-

ent folder. If I Right-click the Imported_Photos folder and 

choose Show Parent Folder it will add the Pictures folder to 

the panel, and Imported_Photos will appear nested under-

neath, just like it exists on my drive.

Alternatively, if you have a top-level folder that you 

don’t want to see displayed in Lightroom, you can Right-

click that folder and choose Hide This Parent to make it go 

away. I don’t want to see the Pictures folder showing at the 

top of my Folders panel, so I will hide that parent to keep 

Imported_Photos at the top. 

find your folders and photos on disk
It’s very important for all Lightroom users to know how to 

find exactly where a given folder or photo resides on their 

drives from inside Lightroom. There are a few ways to iden-

tify where your folders and photos exist on your drive. The 

easiest is the good-old Right-click contextual menu. Go 

ahead and Right-click any folder in the Folders panel and 

choose the Show in Finder (PC: Show in Explorer) menu item. 

This will open your file browser to that folder and show you 

where it exists on your drive. Similarly, you can Right-click 

any photo and access that same Show in menu to take you 

right to that photo in your file browser. You don’t have to 
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go that far to find that information, though. If you just hover 

your cursor over a folder, you should see its path revealed in 

a tooltip pop-up. So take a moment to make sure you know 

exactly where all of your photos are located on your drive.

adding new folders
In typical Lightroom fashion there are a couple of ways to cre-

ate new folders. Let’s imagine a common scenario where you 

buy a new external drive with the intention of storing photos  

on it because your existing drive is filling up. To start, you can 

go to the Library menu and choose New Folder, or click the 

plus sign at the top of the Folders panel and choose Add Folder 

to launch the Choose or Create New Folder dialog (below).

From here you can either choose an existing folder you 

may have created in your file browser or you can create a 

brand-new folder. In this example, I’ll select the drive where 

I want this folder to exist, click the New Folder button, give 

the new folder a name in the New Folder dialog, and click 

Create. I like to have a parent folder named Imported_Photos 

on each drive I use to contain photos managed by Light-

room, so I’ll use that name to create this folder (you can do 

what makes sense for your setup). The new folder will be 

created on that drive, and I can now click the Choose button  

to return to Lightroom where I’ll see I’ve added a new drive 

(note the new Volume Browser) and folder to the Folders 

panel. Now I can use that as a destination during future 

imports, or I can use Lightroom to move photos and folders 

from other locations to that folder. 
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ALL IMAGES BY ROB SYLVAN

Another common scenario is the need to create subfold-

ers within existing folders to help with your organizational 

needs. This process works in a similar fashion, but you start  

by selecting the parent folder within which you want 

to create the subfolder. In this case, I’ll select the new  

Imported_Photos folder I created on the drive named 

Sparta, Right-click to open the contextual menu, and 

choose Create Folder Inside “Imported_Photos” (or 

whatever the name of the folder is that you Right-click). 

This opens a smaller Create Folder dialog where you  

can give the subfolder a name and click Create to com-

plete the process. The subfolder will then appear in  

the Folders panel. These folders are ready to add  

photos and even new folders as your organizational 

needs demand.

removing empty folders
Knowing how to remove folders is important too. The most 

common situation for removing a folder is when you’ve 

deleted all of the photos from the folder for some reason 

or you’ve moved the photos into a different folder. In either 

case, there’s no need to keep an empty and unused folder 

around. Simply Right-click on the empty folder and choose 

Remove. The folder will be removed from the Folders panel, 

and if it was empty, Lightroom will also delete the folder 

from your drive.

What if the folder isn’t empty? Well in the case, when 

you Right-click a folder that has some files in it and choose 

Remove, the folder will only be removed from the Folders 

panel (and the Lightroom catalog). In that situation, Light-

room will open a pop-up warning you that the photos  

will be removed from the Lightroom catalog, but the 

folders and files will remain on disk. This is generally not 

something you’d want to do because you don’t want to 

end up with folders full of photos that aren’t being man-

aged by Lightroom and are just taking up disk space. If you 

want to delete the photos, you need to delete them first 

using Lightroom, then you can remove the empty folder  

as described.

renaming folders
You’ll eventually come to a situation where you need to 

change the name of a folder. This can be accomplished 

easily by Right-clicking the folder and choosing Rename 

from the contextual menu. From there, simply enter the 

new name in the Rename Folder dialog that appears and 

click Save to commit the change. The folder is renamed on 

the drive and that change is reflected in the Folders panel. 

I hope these suggestions help you stay in control of your 

Lightroom library! ■

CLICK TO RATE

https://scottkelby.typeform.com/to/HrHsc6
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the 

Loupe
Taking control of your Lightroom experience involves becoming  

familiar with key Lightroom settings, and even customizing some of 

them to best fit your needs. In my experience, many Lightroom users 

can quite happily use Lightroom for a long time before ever discovering 

the Preferences and Catalog Settings dialogs. I think this is due to the 

fact that most of the default settings are well tuned for the majority of 

users, and that most users are more interested in their photos than 

noodling around in dialogs.

customizing preference  
and catalog settings
B Y  R O B  S Y L V A N
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The moment of discovery of the Preferences often comes hand-

in-hand with something going wrong, and that’s usually not 

the best time to discover anything. So to give you a leg up, or 

at least give you something to file away for if (when) things go 

wrong, I want to share with you a few important settings that 

you might want to customize beyond the defaults.

schedule a backup
One of the most important settings is how often you tell Light-

room to create a backup copy of your catalog file and where 

you want it to be created. You can find the first part of this set-

ting by going to Lightroom (PC: Edit)>Catalog Settings, which 

opens the Catalog Settings dialog. 

On the General tab of the Catalog Settings you’ll find impor-

tant information about your catalog, such as its filename and 

where it’s stored on your hard drive (make sure you know these 

two important facts). At the bottom is where you’ll find the 

option to set the schedule of how often Lightroom creates the 

backup. Just to be clear, Lightroom only creates a copy of the 

catalog file itself. This doesn’t include any photos, previews, 

presets, or anything not contained within the catalog file. For 

this reason, you want to be sure that you have some kind of 

full-system backup process in place that includes all of your 

files. Lightroom simply creates a copy of the catalog file at a 

location of your choosing. 

This may not seem like much help, but the Lightroom cata-

log file contains all of the work you do inside Lightroom (e.g., 

Develop settings, keywords, captions, titles, collection member-

ship, flags, virtual copies, etc.), which is the most important 

thing after your photos. Having a backup copy created on a 

regular schedule can help you in case of disk failure, disk loss, 

As you can see on the Back Up Catalog prompt, there’s a 

Skip this Time button that you can click anytime you’re in a 

hurry. Just don’t skip too often. I like being prompted each time 

I exit Lightroom so I have the option to back up, but in reality 

I may only create a backup once a week or right after a big 

work session. You might also notice the location of the backup 

folder is also shown on that prompt. As a matter of fact, that’s 

the only place you can configure where you want the backup 

copy to be created.

By default, Lightroom puts the backup in a folder (named 

Backups) in the Lightroom folder inside your Pictures folder, 

which is also the default location of your working catalog. This 

isn’t ideal if you want to provide some protection against drive 

failure, so I’d recommend directing the backup to be created on 

a different drive. Click the Choose button to manually navigate 

to and select the location you want the backup to be created. 

On my laptop with only one internal drive I have my backup 

directed to my Dropbox folder so that the backup copies are 

catalog file corruption, or self-inflicted injury, which happens 

when you inadvertently do something in your catalog (like 

delete a saved book collection) and don’t realize it until some 

time down the road. In any one of those situations you’d be 

glad to have a recent backup copy of the catalog that was cre-

ated right before the disaster.

As to the frequency of when this should run, that’s some-

thing you’ll need to decide for yourself. I have mine set to Every 

Time Lightroom Exits. Seem excessive? Well, if you’ve ever had 

to recover using a backup copy of anything, you’ll know that 

the magnitude of relief you felt was directly proportional to 

how recent the backup was created. Plus, Lightroom gives you 

the option to pass up a backup if you just don’t have the time. 

The backup only runs when you exit Lightroom (based on the 

frequency you choose), and at that time you’ll be prompted to 

continue (or not). 
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eventually uploaded to my Dropbox account and synced to my 

other computer. 

I also recommend leaving the integrity test and optimize 

catalog boxes checked. It will make the process take longer, but 

I feel it’s a good investment of time and resources. One final 

note, Lightroom creates a new backup copy each time the pro-

cess runs, and then compresses the backup copy into a zip file 

(Lightroom CC/6 only) to conserve space. Lightroom leaves the 

job of deleting old backup copies up to you. I periodically go into 

my backup folder and delete all but the most recent four or five 

copies to prevent Lightroom from filling my drive with them.

default catalog
On the subject of catalogs, there’s one other vital setting  

I want you to customize for your situation. Go to Lightroom 

(PC: Edit)>Preferences, click on the General tab, and note the 

setting for Default Catalog.

Do yourself a huge favor and change that setting from Load 

Most Recent Catalog to your specific catalog file. Click the 

drop-down menu and you’ll see the path to the current catalog 

displayed as an option, and choose it. If you have more than 

one catalog that you regularly use, then choose the Prompt Me 

when Starting Lightroom to be given the choice of which cata-

log to open each time. The reason this is so important is that 

you (and not Lightroom) need to be in the driver’s seat on the 

decision of which catalog to open. I can’t tell you how many 

lost hours and lost hair I’ve seen over the years because the user 

didn’t realize which catalog was opened when they launched 

the program. If you do nothing else, save yourself from this fate 

and customize that setting for your catalog. 

import options
In the Import Options section of the General Preferences, 

there’s an option to Treat JPEG Files Next to RAW Files as Sepa-

rate Photos, and this is unchecked by default. My suggestion is 

to check that box even if you don’t currently shoot RAW+JPEG.

A fairly common question I get on the KelbyOne Advice 

Desk is from people who start shooting RAW+JPEG and then 

wonder why they can’t actually see the individual JPEG ver-

sions in their catalog (and why they can’t delete them). When 

that option is unchecked, Lightroom copies the RAW and JPEG 

versions from your card, but it only shows you the RAW ver-

sion in the catalog (and treats the JPEG like a hidden sidecar 

file). The thinking is that the RAW is better and that’s the one 

you’ll process in Lightroom, but most people I know who shoot 

RAW+JPEG need access to the JPEG too, so unless you abso-

lutely don’t ever want to see the JPEG version in your catalog, 

my recommendation is to check it. Configure the other options 

on the General tab as you wish. 

cache settings
Over on the File Handing tab there’s one setting worthy of a 

little consideration. In the Camera Raw Cache Settings section 

there’s a place where you can control the size of this cache 

folder shared by Lightroom and the Camera Raw plug-in. This 

cache is used to store a base rendering of your RAW photos 

each time you view them in the Develop module. The larger the 

cache the more data it can hold, which means performance can 

be improved when moving through a large number of RAW 

photos in Develop.

https://kelbyone.com/my-account/helpdesk/
https://kelbyone.com/my-account/helpdesk/
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By default this cache is set to 1 GB, but I’d suggest increas-

ing it anywhere from 5 to 20 GB to see if that comes with any 

performance improvement in Develop. Obviously, this is also 

dependent on how much free space you have on your drive. 

If you have another internal drive with more free space, you 

can click the Choose button and configure the cache to be 

created on that drive instead.

performance
While I’ve seen the number of issues related to this last pref-

erence go down considerably, it’s worth noting in case you 

should encounter it. On the Performance tab of the Preferences 

(only in the latest version of Lightroom), there’s a single check-

box for Use Graphics Processor. When checked, and if your GPU 

is supported, this can improve performance while in the Develop  

module. If you have an older machine, however, and your GPU 

isn’t supported, then you can experience problems. Adobe 

prepared a troubleshooting document to help users solve 

these problems, but the easiest thing to do in the short term 

is uncheck that option if you’re having any odd performance 

https://helpx.adobe.com/lightroom/kb/lightroom-gpu-faq.html
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problems and see if that helps. I have it unchecked on my older 

Windows machine and have no problem.

ALL IMAGES BY ROB SYLVAN

step two: Hold down the Shift and Option keys (PC: Shift 

and Alt keys) while launching Lightroom (keep the keys down 

until you see the prompt).

step three: Choose Reset Preferences when prompted. 

Lightroom will replace the old preferences file with a new one, 

and hopefully solve whatever problem drove you to try this 

trick. Once Lightroom launches, go back and reconfigure any 

of your custom settings.

reset
If Lightroom is ever acting really strangely on you and you can’t 

figure out the cause, it could be worth resetting the prefer-

ences. This got a lot easier in Lightroom CC/6 because Adobe 

added a keyboard shortcut for just this purpose, and they sepa-

rated out the part of the preferences that keeps track of the 

catalog you’re using from the rest (that way resetting the pref-

erences doesn’t also contribute to your having trouble finding 

the correct catalog). Before you do this, it’s worth noting any 

customizations you’ve made so that you can reconfigure them 

after the reset. Here’s how it works:

step one: Quit Lightroom (if you haven’t already).

The rest of the default settings in Lightroom work fairly well 

and most users don’t need to change them, but take the time 

to familiarize yourself with them and then customize them as 

you see fit. ■

https://scottkelby.typeform.com/to/a0n076


Under 
the 

Loupe
The Lightroom catalog file is where all the work you do in Lightroom is 
stored. There may be times when you need to create a smaller version 
of your main working catalog to take on a trip and continue working, or 
perhaps to show to a client on location, and then be able to merge that 
catalog back into your master catalog again. The same process can be 
helpful for anyone who may have created multiple catalogs for other 
reasons and now wishes to merge the data contained within them into 
a single catalog. All of these operations are possible thanks to Light-
room’s catalog export and import functionality. 

managing your catalogs  
for travel and more
B Y  R O B  S Y L V A N
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exporting a smaller catalog
I have one main catalog on my desktop computer that man-

ages all of my photos and contains all of the work I’ve ever 

done in Lightroom; however, sometimes when I travel, I take 

a subset of images with me on my laptop so that I can edit 

those photos and import new photos I create while away. 

Then when I return, I bring all those images back into my 

main catalog. Here’s how I do it:

step one: In the main catalog, create a new collection 

in the Collections panel and name it something that makes 

sense for your purpose (you might include the name of the 

place you’re going, the date, client name, etc.). Here’s a tip: 

When creating the new collection, check the box to Set as 

Target Collection, as this will make it super easy to add pho-

tos to the collection simply by selecting the photo and press-

ing the B key.

step four: After choosing the Export as Catalog option, 

you’ll see the Export as Catalog dialog, where you’ll need to 

make some choices. Let’s go through the options. First, give 

your new catalog a meaningful name so that you know what 

it contains when you see it later. (I’ve named mine Yosemite.) 

Then you need to choose where on your system you want this 

catalog to be created. You can choose an internal drive for 

now and copy it to another drive later, or simply choose a loca-

tion on an external drive that you can connect to your laptop 

and bring with you. In my case, I chose a connected external 

drive (Sparta). 

step two: Add all the photos you want to bring with you. 

step three: Right-click the collection and choose Export 

this Collection as a Catalog. 

Note: It’s not required to create a collection before export-

ing a catalog, as you can simply select any number of pho-

tos and go to the File>Export as Catalog menu to export a 

catalog; however, by creating a collection, it gives you a way 

to thoughtfully gather up the photos you want to bring, no 

matter where they may reside on your drives.

›  ›  l i g h t r o o m  m a g a z i n e  ›  ›
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step five: Now you need to decide what you want to be 

able to do with the photos in this catalog while you travel. Do 

you want the ability to export copies, send a copy to an ex-

ternal editor for additional processing, use Lightroom’s Photo 

Merge options, be able to zoom to 100% in Develop, or to 

print? If so, then you should check the box for Export Nega-

tive Files, which tells Lightroom to include copies of all source 

photos in a folder alongside the exported catalog. 

step six: If you don’t need those types of output possi-

bilities or need to zoom to 100% in Develop, then you can 

save some disk space and uncheck Export Negative Files and 

just use the Build/Include Smart Previews option instead. This 

tells Lightroom to include only smart previews for each of the 

source photos included in this catalog export. Smart previews 

allow you to use the Develop module (albeit with a poten-

tially smaller version of the source photo) even though the 

catalog can’t access the original source photos. You can, of 

course, use all of the other functions for adding and editing 

metadata (keywords, flags, ratings, titles, captions, etc.) with 

smart previews, too. 

In my case, I want the ability to send to an external edi-

tor, so I chose to include negative files, but skipped smart 

previews. Including available previews is a good way to avoid 

having to re-render them later. Once the dialog is config-

ured to your liking, click Export Catalog (PC: Save) to start 

the process of creating the new catalog.

working with the exported catalog
If you exported the catalog to an external drive, you can con-

nect that drive to your laptop (or any other computer running 

Lightroom) and open the exported catalog into Lightroom via 

the File>Open Catalog menu. All of the work you do in that 

catalog while you’re away—from adding metadata to process-

ing in Develop—is stored in that catalog, and can seamlessly be 

transferred later back to your main catalog. 

The catalog (.lrcat), the preview cache (.lrdata), and photos 

(if you opted to include negative files) are all stored in a folder 

with the same name you gave the catalog in the Export as 

Catalog dialog. You can move that folder to any other drive as 

needed to make it work for you. While on my trip, I’ll import 

any new photos I take into that same folder to keep things 

organized and easy for my return. It’s not necessary to add 

new photos to the collection you created earlier because when 

you get back you’re going to transfer all of the data back to 

the main catalog. 

›  ›  l i g h t r o o m  m a g a z i n e  ›  ›
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bringing it all home
Now that I’ve returned from my trip, I want to bring all of 

the changes I made to the original group of photos into my 

original catalog, as well as copy all of my new photos to my 

primary storage location. Here are the steps:

step one: Connect the drive containing the exported cata-

log to the original computer.

step two: Open your main working catalog into Lightroom. 

step three: Go to File>Import from Another Catalog, nav-

igate to the drive containing your travel catalog, select the 

previously exported catalog file, and click Choose.

step four: In the Import from Catalog dialog, you can de-

cide what to do with any new photos, as well as how to handle 

existing photos that changed since exporting the catalog. 

step five: If you imported new photos into this catalog, 

they’ll show up under the New Photos section. In the File 

Handling drop-down menu you can choose to Add New Pho-

tos to Catalog without Moving them (helpful if you want to 

keep the photos in their current location and add them to 

the catalog), Copy New Photos to a New Location and Import 

(most likely choice), or choose not to import them at all (un-

likely). I chose to copy them to a new location and import so 

that they can be stored with my other photos.

step six: If you made any edits to the existing photos while 

you were away, you have some additional choices to make 

in the Changed Existing Photos section. You could choose to 

do nothing, but that seems unlikely if you went through the 

trouble of making the changes. The other two options are to 

replace Metadata and Develop Settings Only, or to replace 

Metadata, Develop Settings, and Negative Files. If you choose 

the option to replace negative files, an additional option is 

enabled below to limit the replacement to non-RAW files, 

which is really the only reason you’d need to replace nega-

tive files (such as making pixel-based changes to a PSD file in 

Photoshop while away). 

›  ›  l i g h t r o o m  m a g a z i n e  ›  ›



› 
› 

p
h

o
t

o
s

h
o

p
 u

s
e

r
 ›

 a
p

r
il

 2
0

16
 

092

step seven: I opted to replace Metadata and Develop Settings 

Only. When you do this, you also have the option to Preserve Old 

Settings as a Virtual Copy via the checkbox below the Replace menu. 

This is really helpful if you’re not sure your new edits are better than 

what was there before (or you can’t remember and want to play 

it safe), but if you know the new work was intended to replace 

the existing settings, then leave that option unchecked and avoid 

creating unwanted virtual copies. When you’re happy with the set-

tings, click Import.

clean up
Once all of the data has been imported into your main catalog and 

the new photos safely copied to a new destination (and backed up), 

you can go back and delete the exported catalog from the external 

drive (and any associated files) using your file browser. That cata-

log was intended to serve a temporary purpose, and now that the 

job is done and you’re home, you don’t want to waste space with 

those files or stumble on it later and not remember what it was for. 

Better to clean up now and be ready for your next adventure with 

a clean slate (drive). 

merging multiple catalogs into one
I regularly encounter people who, for one reason or another, have 

created multiple catalogs when they were learning Lightroom and 

would like to have all of that work contained in a single catalog. 

The same exact process of importing the data from one catalog into 

another can be used to merge any number of catalogs into one; you 

just do it one at a time. Here’s the advice I give them (along with the 

steps shown above):

• Be methodical in your approach. 

• �Outside of Lightroom, you may not know what any one cata-

log file contains. Open each catalog into Lightroom and make 

some notes about the contents of each catalog, its filename, 

and where it’s located on your system.

• Ensure you have a good backup before you start. 

• �Once all data has been imported into one catalog, you’ve con-

firmed all is well, and everything is backed up, go ahead and get 

rid of any catalogs (and associated files) you no longer need. ■

ALL IMAGES BY ROB SYLVAN

›  ›  l i g h t r o o m  m a g a z i n e  ›  ›
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Under 
the 

Loupe
The idea of transferring your Lightroom catalog and all of your  

photos to a new computer can seem daunting at first, but once you 

know the basics you’ll find it’s pretty straightforward. In addition, com-

pleting the process will make you a more confident Lightroom user.

transferring your lightroom catalog 
and photos to a new computer
B Y  R O B  S Y L V A N
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I first wrote about this subject for Photoshop User magazine 

back in 2010, but I still get a lot of questions on this topic, so  

I thought it was time for an update. Within the context of trans-

ferring Lightroom to a new computer, there are essentially three 

components that you want to transfer from your old computer 

to the new machine:

1. Your photos

2. All custom presets, templates, and third-party plug-ins

3. �The Lightroom catalog (and possibly its associated 

preview cache files).

I want to point out that there are a few ways to successfully 

migrate this stuff to a new computer, but I’m going to highlight 

one method that will get all of your data safely copied to a new 

computer, keep you in the driver’s seat every step of the way, 

and ensure that you know where all your files are when the job 

is done. While I’m writing this with a focus on Lightroom 5, the 

basic steps also apply to earlier versions of Lightroom. 

before you start
While you can transfer files over a network connection, having a 

large capacity external drive (or multiple external drives depend-

ing on the amount of photos you have) is going to make this 

process much simpler and faster, and that’s the method I recom-

mend. Also, do yourself a favor and make sure you have a good, 

solid backup in place before you begin. 

The process I’m going to share works just as well if you’re 

transferring between two computers with the same operating 

system or two different operating systems. The Lightroom cat-

alog is cross-platform compatible, which means a catalog that 

started on Mac can be opened in Windows, or vice versa. Note: If 

you’re migrating between Mac and Windows, you’ll want to use 

an external drive that’s formatted as FAT32 because both Mac 

and Windows can read and write to and from a FAT32-formatted 

drive. An alternative is to use third-party software that lets a Mac 

computer read and write to a Windows NTFS-formatted drive, or 

that allows a Windows computer to read and write to Mac OS 

Extended (this is what I do). 

preparing the new computer
The main thing to do on the new computer is to install the latest 

version of Lightroom. You can skip the original installation disc 

and simply download the installer for the latest version you own 

by going to:

Mac: www.adobe.com/support/downloads/product.jsp?product=

113&platform=Macintosh

PC: www.adobe.com/support/downloads/product.jsp?product=

113&platform=Windows

If you’re a Creative Cloud subscriber, you can just log into the 

CC on the new computer and install Lightroom that way. The End 

User License Agreement allows you to install a second copy of the 

software for your own exclusive use on another computer, pro-

vided that Lightroom isn’t used on both computers at the same 

time. This is also true for Creative Cloud subscriptions. Lightroom 

is truly cross-platform, so even if you’re changing operating sys-

tems (Mac to PC or PC to Mac), you can use your same serial 

number with both installations, and there’s no activation software 

involved. Don’t bother launching Lightroom yet on the new com-

puter, just install the software and go back to the old computer 

so we can gather up all the pieces to bring over.

migrating your photos
Stored in your Lightroom catalog is the complete path to each 

imported photo, from the volume name (PC: drive letter) to 

the filename, and every folder in between. If something in that 

path changes outside of Lightroom, then the path stored in the 

catalog becomes out of sync with your photos’ actual location. 

In the process of migrating from one computer to another, it’s 

likely that something in that path will change. This isn’t a big 

deal, and the process to update the catalog at the folder level is 

very straightforward (we’ll go over that when we get to the new 

computer). The moral of the story is that if all your photos are 

stored in a single parent folder (no matter how many subfolders 

are in it), when you get to the new computer, you only need to 

update a single folder to get every subfolder and photo up to 

date. I realize that there’s no single right way to store photos and 

your photographic situation may be slightly more complicated 

for good reason, in which case you may need to update more 

than one folder.

For example, on every drive I use to store photos, I maintain 

a structure that starts with a single parent folder that contains 

multiple levels of subfolders for all the photos. This keeps things 

very simple for portability and backup. This parent folder is at the 

top of the tree in the Folders panel. If I open a Windows Explorer 

window to that same location, you can see the same folder struc-

ture is shown there, too (see next page). 
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What if you do keep all your photos in a single folder, but the 

top-level folder isn’t showing in the Folders panel? Just Right-click 

on the topmost folder and choose Show Parent Folder from the 

contextual menu that appears. That will bring the parent folder 

into the Folders panel. On the flip side, if you have too many lev-

els of parent folders showing in the Folders panel, you can hide 

unnecessary folders by Right-clicking on the topmost folder and 

choosing Hide This Parent. Typically, having one level of parent 

folder above the folders containing your actual photos works best.

If your photos are already on an external drive that you’re mov-

ing to the new computer, then there’s no need to copy your pho-

tos to yet another drive. Just be prepared to connect that drive to 

the new computer, and skip ahead to the next section on presets 

and plug-ins.

If you need to migrate your photos to an external drive, here’s 

what to do: With Lightroom closed, copy (don’t move) the par-

ent folder containing your photos (and its contents as-is) to the 

external drive you’re using to transfer the data. Remember, don’t 

change the existing structure; just copy it to the external drive.

presets and plug-ins
Now it’s time to gather up all your custom presets, plug-ins, and 

templates. If you’ve never created custom presets or templates, 

and you’ve never installed a third-party plug-in or Web gallery, 

then you can skip this part of the process and we’ll see you in 

the section on the catalog. When you install Lightroom on your 

new computer you’ll get all the default presets and templates, so 

we’re only concerned with all the custom bits you added. 

In my experience, most people leave their presets and tem-

plates in the default central location. The simplest way to access 

this location is to go to Lightroom (PC: Edit)>Preferences, click 

on the Presets tab, and click the Show Lightroom Presets Folder 

button. This will open the folder, named Lightroom, containing 

all of your presets into Finder (PC: Windows Explorer), which is 

located here:

Mac: �Users/[username]/Library/Application Support/ 

Adobe/Lightroom

PC: Users\[username]\AppData\Roaming\Adobe\Lightroom
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Note: Windows can hide the AppData and Application Data 

folders. In Windows Explorer, go to Tools>Folder Options>View, 

and check Show Hidden Files, Folders, and Drives. Mac does a 

similar thing with the Library folder. Open a new Finder window, 

click Go in the menu bar, and hold the Option key to make Library 

magically appear in the list of places to go. Choose Library, and 

then follow the rest of the path above.

On the Presets tab in Preferences, if you already had Store Pre-

sets with This Catalog checked, then I assume you know where 

all your presets are, and you can skip ahead to the catalog section. 

If you don’t have Store Presets with This Catalog checked, then 

don’t check it now, as it will simply create a new folder (named 

Lightroom Settings) alongside your catalog with only the default 

presets, which won’t help with your custom presets.

In this Lightroom folder are all your presets, templates, third-

party Web galleries (if installed), and the most common location 

for third-party plug-ins (the Modules folder), within their respec-

tive subfolders. Your task is to place a copy of all your custom 

files on the external drive destined for the new computer, and the 

easiest way to do that is to copy the entire Lightroom folder to 

the external drive. On Windows, the Lightroom preference file is 

also stored in the Lightroom folder in a folder named Preferences.  

I don’t recommend bringing a copy of this file to the new com-

puter, as I think it’s wiser to start with a fresh preference file on 

the new computer. In addition, if you’re migrating from Windows 

to Mac, the preferences are stored in a different location on Mac 

anyway, so leave the Preferences folder behind.

Regarding third-party plug-ins, I’ve always found it simplest 

to place a copy of the .lrplugin file (the file extension for Light-

room plug-ins) in the Modules folder so that the Plug-in Man-

ager (File>Plug-in Manager) will automatically add and enable the 

plug-ins. However, you may have chosen to store your plug-ins in 

a different location and manually add them via the Plug-in Man-

ager. There’s no wrong answer, but I’ll leave it to you to know 

where your plug-ins are stored if not in the Modules folder. 

Lightroom plug-ins are typically cross-platform, but some may 

have special requirements for each operating system, so be sure 

to check the website of the plug-in author for all compatibility 

concerns. If you have installed plug-ins that are more like external 

editors, such as those from Nik Software or onOne Software that 

you access via the Photo>Edit In menu, then you’ll want to go 

to the developer’s website and download the installers for those 

plug-ins to the new computer and install them like new software 

at the end of the transfer process. Now that you have all your 

photos, presets, and plug-ins copied to your external drive, let’s 

turn our attention to the Lightroom catalog.

Tip: While you have Lightroom open, take note of your 

preference settings so that you can reconfigure them on the 

new computer. 

copying the catalog
When it comes to migrating the actual Lightroom catalog,  

I advocate creating a copy of your working catalog to transfer to 

the new computer because there’s no other way to transfer the 

Publish Services connections you previously set up in the Library 

module, as they’re not included in a catalog export. In addi-

tion, a catalog export only includes keywords that are applied 

to exported photos, which may leave out parts of your entire 

keyword hierarchy that have not yet been applied to photos 

(though it’s possible to export a keyword list and import it into 

a new catalog). 

To find your catalog, go to Lightroom (PC: Edit)>Catalog Set-

tings, click on the General tab, and click the Show button to 

reveal its location. The default location of the catalog is in the 

Pictures folder, but the Lightroom catalog can exist at another 

location of your choosing. 

In the folder containing the catalog are two (possibly three if 

you use smart previews) important files: the catalog itself with 

the .lrcat file extension and the associated preview cache with 

the .lrdata file extension. If you see a .lock or .journal file, then 

close Lightroom and they will go away, as they are temporary 

files that assist the catalog. If you created smart previews at some 

point, you’ll also see a Smart Previews.lrdata file. If you’ve never 

changed the default location of the catalog backups, then you 

might see a Backups folder, as well, but we can leave that folder 

behind. With Lightroom closed, copy (not move) the .lrcat and 

.lrdata files to a folder on the external drive. If you can fit them on 

the same drive holding your photos, then go for it. If you need to 

use a separate drive, that’s fine, too. 

You should now have a copy of your photos, presets, and 

catalog on the external drive. Safely disconnect the external drive 

from the old computer and connect it to the new computer. 

transferring to the new computer
Launch your file browser on the new computer and view the con-

tents of the external drive. For illustration purposes, I’m transfer-

ring my catalog from a Windows machine to a Mac. First, copy 

the folder containing the Lightroom catalog (and preview cache) 

to a location of your choosing on the new computer. Then, copy 

your photos’ folder structure to a new location of your choosing 

(or leave them on the external drive if that’s your plan). When 
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those copy operations are complete, navigate to the catalog in its 

new home and double-click the .lrcat file to open it in Lightroom. 

Don’t panic if you see question marks on your folders and pho-

tos, you just need to update the catalog to point to the their new 

location. This is when having a single parent folder showing in 

the Folders panel comes in handy. To point the folders to the new 

location, follow these steps: 

step one: Right-click the top-level parent folder and choose 

Find Missing Folder.

step two: Navigate to and select that exact folder in its new 

location and click Choose (PC: OK).

Lightroom will then go through the process of updating the 

catalog to reference that folder (and everything inside of it) at this 

new location. Repeat the process for any folders not contained in 

that parent folder, if you have any.

Next, go to Lightroom (PC: Edit)>Preferences and reconfigure 

your settings. I suggest that you configure the Default Catalog in 

the General tab to reference this catalog specifically instead of load-

ing the most recent catalog. Once configured, go to the Presets tab 

and click the Show Lightroom Presets Folder button to open it in 

your file browser. Copy all your custom presets, templates, plug-

ins, and Web galleries from the external drive to their respective 

folders on the new computer. Restart Lightroom when the copy 

operation is complete to see your custom bits in Lightroom.

Go to File>Plug-in Manager and make sure all your plug-ins 

are installed and running. If you haven’t already, this is a good 

time to make sure you’re running the latest version of each one. 

You’ll need to reregister any third-party plug-ins you had running 

on the old computer.

a word about publish  
services connections
Connections that were set up on the old computer to online 

sources such as SmugMug or Flickr should still work, but give 

them a test drive to make sure. However, existing hard drive con-

nections will display any photos they contain, but may no longer 

function due to the change in drives. The export location of an 

existing connection cannot be changed after the connection is 

created, and it will have to be rebuilt by making a new hard drive 

connection on the new computer. Once you create the new hard 

drive connection, you can repopulate its contents to match the 

old connection and you’ll be back in business. 

Give your catalog a thorough walk through to make sure there 

are no lingering question marks on any files, that all your presets 

are accounted for, and everything is functioning as it should. 

If you’re satisfied that all is well, you can close Lightroom and 

install any additional third-party plug-ins (such as the kind from 

onOne Software) if you have them. Congratulations on the suc-

cessful migration! n
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